free hit counters
SWGenGUI (the shrinking automator) - Page 2 - The Process Forum
The Process Forum  

Go Back   The Process Forum > Content Forums > Shrinking Process

Inflation and Process ClipsProcess Productions Store Inflation and Process Clips

Reply
Thread Tools Display Modes
Unread 02-21-2018   #13
swfn
Mad Scientist
 
swfn's Avatar
 
Join Date: Nov 2015
Posts: 44
Re: SWGenGUI (the shrinking automator)

Quote:
Originally Posted by Jaran View Post
This is really well done and the tutorials are clear and easy to follow.

Awesome work.
Thank you very much for your feedback, I am glad you liked it and found the tutorials useful.

Here comes the third one. Probably this is going to be the last "instructive" tutorial. Maybe I will be uploading a last one explaining in general terms the features not covered in the previous tutorials (except those being self-explanatory), but nothing else.

Tutorial 3 (miscellaneous)

The extraction password is attached in the image below.
Attached Images
File Type: png Password3.png (2.3 KB, 41 views)
__________________
swfn is offline   Reply With Quote
Unread 02-22-2018   #14
vid
Frequent Poster
 
Join Date: Jan 2007
Posts: 263
Re: SWGenGUI (the shrinking automator)

I unzipped the content and clicked the application:

"This app can't run on this PC"
vid is online now   Reply With Quote
Unread 02-22-2018   #15
swfn
Mad Scientist
 
swfn's Avatar
 
Join Date: Nov 2015
Posts: 44
Re: SWGenGUI (the shrinking automator)

Quote:
Originally Posted by vid View Post
I unzipped the content and clicked the application:

"This app can't run on this PC"
This is most likely because you are using a 32-bit Windows OS. The program has only been compiled for 64-bit systems.

I happened to find a couple of bugs with not-so-tested features while I was doing the last tutorial. Since now I am developing the 1.1 version fixing these bugs, I will try to compile it also for 32-bit systems and release it for both architectures once I fix them.
__________________
swfn is offline   Reply With Quote
Unread 02-22-2018   #16
vid
Frequent Poster
 
Join Date: Jan 2007
Posts: 263
Re: SWGenGUI (the shrinking automator)

Quote:
Originally Posted by swfn View Post
This is most likely because you are using a 32-bit Windows OS. The program has only been compiled for 64-bit systems.

I happened to find a couple of bugs with not-so-tested features while I was doing the last tutorial. Since now I am developing the 1.1 version fixing these bugs, I will try to compile it also for 32-bit systems and release it for both architectures once I fix them.
You're right, I was looking at "x64 processor" but it's a 32-bit.

Don't want to rush you in any way, but I'm looking forward to if you can ever make the other version. Thanks!
vid is online now   Reply With Quote
Unread 02-24-2018   #17
swfn
Mad Scientist
 
swfn's Avatar
 
Join Date: Nov 2015
Posts: 44
Re: SWGenGUI (the shrinking automator)

Quote:
Originally Posted by vid View Post
You're right, I was looking at "x64 processor" but it's a 32-bit.

Don't want to rush you in any way, but I'm looking forward to if you can ever make the other version. Thanks!
I have already compiled a 32-bit version. You can find it in the first post or downloading it here:

SWGenGUI-1.1 (32-bit)

For those using the 64-bit version, it is also recommended to upgrade to the newer 1.1 version:

SWGenGUI-1.1 (64-bit)

As for the 32-bit version, I am afraid to tell that you may experience random crashes when trying to generate the video. The encoder used in this application (x264) is very RAM consuming and it easily reaches the maximum 2 GB RAM limit that a process is allowed to reach in 32-bit OS. I have spent many hours trying to figure out why these crashes happened, thinking there was an error in my code that somehow went unnoticed in the 64-bit version, but I finally found out that it was due to that limitation.

In order to avoid as much as possible these crashes, you should avoid encoding with a resolution of 1080p (1920x1080), and instead encode with a resolution of 720p (1280x720) or any custom resolution below that one. You can change these settings in Edit/Setup. Anyway, I will upload soon the last tutorial focusing on all these features not covered in the previous ones.

In short, unless you are using an old processor with x86 architecture (32-bit) forcing you to use a 32-bit OS, stick to the 64-bit version of the application.
__________________

Last edited by swfn; 04-14-2018 at 09:51 AM. Reason: Updated links.
swfn is offline   Reply With Quote
Unread 02-25-2018   #18
swfn
Mad Scientist
 
swfn's Avatar
 
Join Date: Nov 2015
Posts: 44
Re: SWGenGUI (the shrinking automator)

And here comes the last tutorial:

Tutorial 4 (advanced)

The extraction password is attached in the image below.
Attached Images
File Type: png Password4.png (2.4 KB, 9 views)
__________________
swfn is offline   Reply With Quote
Unread 04-14-2018   #19
swfn
Mad Scientist
 
swfn's Avatar
 
Join Date: Nov 2015
Posts: 44
Re: SWGenGUI (the shrinking automator)

New version 1.2. Focused mainly on improving the performance of the 32-bit version.

SWGenGUI-1.2 (64-bit)
SWGenGUI-1.2 (32-bit)
__________________
swfn is offline   Reply With Quote
Unread 05-01-2018   #20
swfn
Mad Scientist
 
swfn's Avatar
 
Join Date: Nov 2015
Posts: 44
Re: SWGenGUI (the shrinking automator)

New version 1.3. All changes are indicated in the first post.

SWGenGUI-1.3 (64-bit)
SWGenGUI-1.3 (32-bit)
__________________
swfn is offline   Reply With Quote
Unread 05-01-2018   #21
Melkorios
Frequent Poster
 
Melkorios's Avatar
 
Join Date: Apr 2007
Posts: 238
Re: SWGenGUI (the shrinking automator)

You know, it's weird. I'm compiling the MP4 files as instructed in the first tutorial video, but the resulting videos don't seem to compile or load properly, as there's no imagery at all when I go to view them.
Melkorios is offline   Reply With Quote
Unread 05-02-2018   #22
swfn
Mad Scientist
 
swfn's Avatar
 
Join Date: Nov 2015
Posts: 44
Re: SWGenGUI (the shrinking automator)

Quote:
Originally Posted by Melkorios View Post
You know, it's weird. I'm compiling the MP4 files as instructed in the first tutorial video, but the resulting videos don't seem to compile or load properly, as there's no imagery at all when I go to view them.
This is most likely because your player does not accept encoded videos with YUV444p pixel format.

Go to "Edit/Setup..." (or press "M") and in the "Pixel format:" field, change "YUV444p" by "YUV420p". That should do the trick, albeit the quality will be significantly lower.
__________________
swfn is offline   Reply With Quote
Reply

Tags
automator, shrinking woman, software, swgen, swgengui

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 09:01 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.